npm install 报错node-pre-gyp ERR!

最近想安装bcrypt npm i bcrypt -S命令后,总是报错

这一安装,报了这么多错误,吓死哥了,只能求助百度

百度之后,采用网上的方案

步骤一

  • npm install –global –production windows-build-tools
  • npm install -g node-gyp

步骤二

上面步骤一如果没有安装好python2.7,则安装下

npm install –python=python2.7

npm config set python python2.7

步骤三

npm i bcrypt -S

一番折腾后,bcrypt安装成功,这个问题之前就遇到过,以前没在意,就一直忽略,最近学习koa ,其中有用到加密的部分,这部分就不得不解决啊,困扰好久,结合别人的经验,解决了这个问题,记下来,以免以后再找资料

本网页由快兔兔AI采集器生成,目的为演示采集效果,若侵权请及时联系删除。

原文链接:https://blog.csdn.net/qfxlw/article/details/85331869

更多内容