Could not initialize class ru.yandex.clickhouse.ClickHouseUtil

我们自己实现Flink Clickhouse时,在测试阶段抛出Could not initialize class ru.yandex.clickhouse.ClickHouseUtil

经过反复定位,最终发现是因为guava依赖版本过低导致的,原来的版本是13.0.1

<dependency> <groupId>com.google.guava</groupId> <artifactId>guava</artifactId> <version>13.0.1</version> </dependency>

所以升级了依赖版本到30.1.1-jre 成功解决了问题

定位记录一下,避免大家踩坑

 

本网页由快兔兔AI采集器生成,目的为演示采集效果,若侵权请及时联系删除。

原文链接:https://blog.csdn.net/Hdu_lc14015312/article/details/118584190

更多内容